Intellect Board — cистема управления сайтом

Построение сайта на основе форума

Intellect Board — cистема управления сайтом »   Техническая поддержка версии 2.19 »   show_news_feed не работает?
RSS

show_news_feed не работает?

пытаюсь вывести последние новости

Текущий рейтинг темы: Нет
Выводить сообщения

<<Назад  Вперед>>Модераторы: aerograf, wsxПечать
 
Yuras
Долгожитель форума


Всего сообщений: 382
Рейтинг пользователя: 11


Ссылка


Дата регистрации на форуме:
15 мар. 2007
Пытаюсь вывести последние новости, вставляя в шаблон
<? show_news_feed(22,"Новости сайта",10,60); ?>

Обработка кода просто прекращается на этом месте и выдает пустое место.

В чем может быть причина?
Serega McKane
Почетный участник


Откуда: Ижевск
Всего сообщений: 175
Рейтинг пользователя: 0


Ссылка


Дата регистрации на форуме:
26 июня 2006
У тебя как я понял по новому варианту шаблон сделан, одним файлом? У меня по старому - майн.пхп и отдельно файл основного шаблона. Работает.

---
techmaniacs.net - Портал компьютерных энтузиастов - мой сайт на intellect Board
Yuras
Долгожитель форума


Всего сообщений: 382
Рейтинг пользователя: 11


Ссылка


Дата регистрации на форуме:
15 мар. 2007
у меня установлен шаблон от wsx (Gray). в нем нет файла main.php.
в родительском скине - abstract, наверное, должна эта функция быть расписана?
а как у тебя в main.php она выглядит?

есть эта функция у меня только в корневом common.php. сборка последняя со всеми патчами. :frown:
4X_Pro
Руководитель Проекта
Настоящий Компьютерщик
4X_Pro
Откуда: Москва
Всего сообщений: 3299
Рейтинг пользователя: 70


Ссылка


Дата регистрации на форуме:
29 сен. 2001
В стилевом main.php должны быть такие функции:

function news_feed_start($msg,$rsslink) { ?>
<br>
<table class="innertable" width="100%" cellspacing=1><tr><td class="tablehead" width="100%">
<?=$msg;?><td class="tablehead" width=32><a href="<?=$rsslink;?>">
<img border=0 alt="RSS" src="<?=$GLOBALS['opt_url']."/styles/".$GLOBALS['inuser']['st_file']."/rss.png";?>"></a>
<tr><td colspan=2><? }

function news_feed_entry(&$tdata) { ?>
<?=short_date_out($tdata['p__time']);?> &mdash; <a href="<?=build_url($tdata);?>"><?=$tdata['t_title'];?></a><div class="descr"><?=$tdata['t_descr'];?></div>
<? }

function news_feed_noentries(&$tdata) { ?>
<?=MSG_n_nonews;?>
<? }

function news_feed_end() { ?>
</table>
<? }

---
Спорить со мной по поводу того, что в IntB будет, а чего нет -- бесполезно!
4X_Pro
Руководитель Проекта
Настоящий Компьютерщик
4X_Pro
Откуда: Москва
Всего сообщений: 3299
Рейтинг пользователя: 70


Ссылка


Дата регистрации на форуме:
29 сен. 2001
Только что проверил — в Grey их действительно не было. Добавил.

---
Спорить со мной по поводу того, что в IntB будет, а чего нет -- бесполезно!
Yuras
Долгожитель форума


Всего сообщений: 382
Рейтинг пользователя: 11


Ссылка


Дата регистрации на форуме:
15 мар. 2007
все отлично! работает. спасибо! :thumbup
<<Назад  Вперед>>Модераторы: aerograf, wsxПечать
Intellect Board — cистема управления сайтом »   Техническая поддержка версии 2.19 »   show_news_feed не работает?
RSS

1 посетитель просмотрел эту тему за последние 10 минут
В том числе: 1 гость, 0 скрытых пользователей

Последние RSS
Ограничение доступа
не отображаются разделы
Архив версий
Установка стиля на Intellect Board 2.22
Завершилась работа над новой версией 3.00

Самые активные 5 тем RSS


Время выполнения скрипта: 0.0685. Количество выполненных запросов: 17, время выполнения запросов 0.0000
Creative Commons License Rambler's Top100 Rambler's Top100 Рейтинг@Mail.ru Valid HTML 4.01 Transitional Valid CSS!