Intellect Board — cистема управления сайтом

Построение сайта на основе форума

Intellect Board — cистема управления сайтом »   Техническая поддержка версии 2.19 »   Опять админка
RSS

Опять админка

При входе не пускает

Выводить сообщения

<<Назад  Вперед>>Модераторы: aerograf, wsxПечать
 
cwll
Новичок


Всего сообщений: 3
Рейтинг пользователя: 0


Ссылка


Дата регистрации на форуме:
1 окт. 2006
Выглядит это так: при введнном пароле перенаправляется не на
/admin/index.php а на /index.php. После этого впадает в ступор. PHP 4.43. На Денвере с PHP 5 все ОК. И из Оперы и из Осла.

Наверняка какая-то мелочь, самому копать лень. Может с правами что напутал... Выхожу из положения набором правильного адреса вручную.

Обычным юзером все нормально входит.

Собственно, помощь мне не нужна, проблема небольшая. Просто думаю, что это как-то пофиксить бы не мешало.

Вдогонку:
не желает из бекапа восстанавливаться. Задумывается и вылетает по 30 секундному таймауту. Пробовал ему chmod 777 поставить - бестолку. Пробовал скачать и загрузить ему с локального компа - тоже не берет.

Продолжение поэмы о неудачной установке: не знаю от чего, но половина форума кракозябры. С бэкапа та ж фигня. Переустановил - теперь в админку не пускает вообще. Не админ, говорит. Пробовал через настройку - не админ один хрен.

Согласен бОльшую часть списать на свои кривые руки и кэш. Но ИМХО сыроват пока релиз. Поспешили.

Откачусь-ка я от греха.

И чтобы это не выглядело потоком наездов - скрипт отличный по задумке. Довести б его до состояния, чтобы с бубном не прыгать - вообще б цены не было.
ZoRDaK
Участник

ZoRDaK
Откуда: Россия, Сибирь... :))) Омск
Всего сообщений: 69
Рейтинг пользователя: 3


Ссылка


Дата регистрации на форуме:
14 июля 2005

cwll написал:
[q]

Вдогонку:
не желает из бекапа восстанавливаться. Задумывается и вылетает по 30 секундному таймауту. Пробовал ему chmod 777 поставить - бестолку. Пробовал скачать и загрузить ему с локального компа - тоже не берет.
[/q]

отписался тебе личкой.... это проблема не к разработчикам форума а к твоим рукам и опыту. будут проблемы пиши. мож и смогу чем еще помочь

---
Мыслю! Следовательно существую...
cwll
Новичок


Всего сообщений: 3
Рейтинг пользователя: 0


Ссылка


Дата регистрации на форуме:
1 окт. 2006

ZoRDaK написал:
[q]
отписался тебе личкой.... это проблема не к разработчикам форума а к твоим рукам и опыту. будут проблемы пиши. мож и смогу чем еще помочь
[/q]


Ты не понял. На хостинге 30 секунд. Как это фиксить я в курсе. Кстати, способов как минимум 2.

Я сам пишу на PHP и в принципе могу зафиксить баги, но с бубном, как я сказал, прыгать нет настроения. Я даже готов списать половону багов на свои кривые ручки. Вопрос не в этом.

Вопрос, по большому счету, что версия крайне сырая. Вот пример:

Идем сюда:
http://intboard.ru/index.php?o...m=filelist

Выбираем "по размеру файла" и пытаемся отсотрировать по возрастанию или убыванию. Я не обнаружил различий.

При всем респекта к разработчикам - багов в релизе больше чем у Билла Гейтса в Висте.
4X_Pro
Руководитель Проекта
Настоящий Компьютерщик
4X_Pro
Откуда: Москва
Всего сообщений: 3299
Рейтинг пользователя: 70


Ссылка


Дата регистрации на форуме:
29 сен. 2001
Кракозябры — из-за неправильной кодировки. Что с этим делать — описано в !readme!.txt (достаточно раскомментировать одну строку в db/mysql.php). Делать принудительное задание кодировки при создании таблиц я не стал потому, что в некоторых ситуациях это приводит к обратному результату (я уж не говорю о том, что mysql 3.23 вообще не знает, что такое кодировки и установка там станет невозможной).
Насчет / вместо admin/ — сказать затрудняюсь, советую проверить правильность написания URL форума в настройках.
Насчет 30 секунд на хостинге — это при каком объеме базы такое происходит?

---
Спорить со мной по поводу того, что в IntB будет, а чего нет -- бесполезно!
cwll
Новичок


Всего сообщений: 3
Рейтинг пользователя: 0


Ссылка


Дата регистрации на форуме:
1 окт. 2006

XXXX Pro написал:
[q]
Кракозябры — из-за неправильной кодировки. Что с этим делать — описано в !readme!.txt
[/q]

Скорее всего. Но в первый раз это был бэкап базы, потом переустановка с удалением всех таблиц в старой. Первая установка прошла нормально и без раскомментирований - что удивительно. А почему при этом в админку-то не пускала - логины были латиницей.

XXXX Pro написал:
[q]
Насчет / вместо admin/ — сказать затрудняюсь, советую проверить правильность написания URL форума в настройках.
[/q]
Я тоже так подумал. Проверил - нормальные урлы. В код я не лазил. Смотрел лог - броузеру не передается ничего, как будто кто-то вилку выдернул.

XXXX Pro написал:
[q]
Насчет 30 секунд на хостинге — это при каком объеме базы такое происходит?
[/q]
В то-то и дело, что база пустая. Сразу после установки. Права 777 на директории. Может что у хостера криво настроено. Забыл сказать - она гзипована была, но если смогло загзиповаться - отчего разгзиповаться не может...

Короче, надо было с бубном побезать. \":)\"

На счет Мускула - нельзя там что-то типа if charset .... set... сделать?
<<Назад  Вперед>>Модераторы: aerograf, wsxПечать
Intellect Board — cистема управления сайтом »   Техническая поддержка версии 2.19 »   Опять админка
RSS

1 посетитель просмотрел эту тему за последние 10 минут
В том числе: 1 гость, 0 скрытых пользователей

Последние RSS
Ограничение доступа
не отображаются разделы
Архив версий
Установка стиля на Intellect Board 2.22
Завершилась работа над новой версией 3.00

Самые активные 5 тем RSS


Время выполнения скрипта: 0.0605. Количество выполненных запросов: 17, время выполнения запросов 0.0000
Creative Commons License Rambler's Top100 Rambler's Top100 Рейтинг@Mail.ru Valid HTML 4.01 Transitional Valid CSS!