Intellect Board — cистема управления сайтом

Построение сайта на основе форума

Intellect Board — cистема управления сайтом »   Техническая поддержка версии 2.18 »   Взлом форума
RSS

Взлом форума

Текущий рейтинг темы: Нет
Выводить сообщения
Правила раздела

<<Назад  Вперед>>Модераторы: aerograf, wsxПечать
 
el_pueblo
Новичок


Всего сообщений: 24
Рейтинг пользователя: 0


Ссылка


Дата регистрации на форуме:
1 мар. 2007
С утра зашёл на форум - главная страница работает только с оформлением "abstract" (слетел дизайн форума). Через FTP скачал лог ошибок из папки config - там идут сообщения о попытках взлома с разных IP-адресов.
В админку перейти удаётся, но никаких действий из неё не получается сделать - GLOBAL ADMIN ERROR: 2 (require(../config/database.php) [< line 18) require(../config/database.php) [<a href='function.require'>function.require</a>]: failed to open stream: Permission denied.
На заглавной странице внизу следующее:
Warning: fopen(config/error.log) [function.fopen]: failed to open stream: Permission denied in /home/sites/site303/web/forum/index.php on line 337

Warning: fputs(): supplied argument is not a valid stream resource in /home/sites/site303/web/forum/index.php on line 343

Warning: fclose(): supplied argument is not a valid stream resource in /home/sites/site303/web/forum/index.php on line 344

GLOBAL FORUM ERROR: common.php (line 1485) - fopen(/home/sites/site303/web/forum/config/iboard.php) [<a href='function.fopen'>function.fopen</a>]: failed to open stream: Permission denied

Ни в один раздел форума зайти не получается.
И что дальше с этим делать?? \":(\"
Gram
Администратор

Gram
Откуда: Нижний Новгород
Всего сообщений: 1011
Рейтинг пользователя: 38


Ссылка


Дата регистрации на форуме:
23 июля 2003
el_pueblo, ну для начала проверьте что там твориться с файлами в папке config — посмотрите права, не побились ли они. Да и вообще на папку config права проверьте (и существует ли она?).
el_pueblo
Новичок


Всего сообщений: 24
Рейтинг пользователя: 0


Ссылка


Дата регистрации на форуме:
1 мар. 2007
Папка config на месте, права на все файлы - 700.
Сейчас уже совсем страница не грузится, выдаёт
GLOBAL FORUM ERROR: index.php (line 20) - require(config/database.php) [<a href='function.require'>function.require</a>]: failed to open stream: Permission denied
Gram
Администратор

Gram
Откуда: Нижний Новгород
Всего сообщений: 1011
Рейтинг пользователя: 38


Ссылка


Дата регистрации на форуме:
23 июля 2003
Ну на самом деле я еще просил проверить не битые ли файлы эти, это во-первых, а во-вторых, кто владелец файлов (какой пользователь) и от какого пользователя выполняются скрипты. Возможно на хостере чего то сбилось врезультате чего скрипты начали выполняться от другого пользователя и прав 700 на них не хватает.
el_pueblo
Новичок


Всего сообщений: 24
Рейтинг пользователя: 0


Ссылка


Дата регистрации на форуме:
1 мар. 2007
Разобрался вроде бы....
Хостер сегодня ночью переключил режимы запуска php с cgi на mod_php и молчит!
Сейчас проснулись, всё объяснили, теперь буду права доступа все менять. :mad:
el_pueblo
Новичок


Всего сообщений: 24
Рейтинг пользователя: 0


Ссылка


Дата регистрации на форуме:
1 мар. 2007
В догонку - в папке config в error.log куча записей вроде
"Date: Tue, 12 Feb 2008 05:09:32 +0300, IP: 64.22.102.130,, User - , Module: http://www.chatvrb.com/lol.jpg?, Action:
Hack attempt! Module: http://www.chatvrb.com/lol.jpg?"
Т.е. пишется, что "Попытка взлома", ай-пишник и адрес каких-то сайтов (причём постоянно разных).
Что это за попытки взлома? Ну и, соответственно, как с ними бороться?
4X_Pro
Руководитель Проекта
Настоящий Компьютерщик
4X_Pro
Откуда: Москва
Всего сообщений: 3299
Рейтинг пользователя: 70


Ссылка


Дата регистрации на форуме:
29 сен. 2001
el_pueblo, это автоматизированные попытки найти уязвимые скрипты. Т.е. взламывается чей-то чужой сайт, а потом он начинает искать типовые уязвимости в других сайтах. Сделать с этим вряд ли чего получится, просто игнорируй. Раз такое сообщение выдалось, то в IntB данная уязвимость не сработала. Если слишком часто идут попытки с одного IP, забань его (это можно только в 2.19 и выше).

---
Спорить со мной по поводу того, что в IntB будет, а чего нет -- бесполезно!
<<Назад  Вперед>>Модераторы: aerograf, wsxПечать
Intellect Board — cистема управления сайтом »   Техническая поддержка версии 2.18 »   Взлом форума
RSS

1 посетитель просмотрел эту тему за последние 10 минут
В том числе: 1 гость, 0 скрытых пользователей

Последние RSS
Ограничение доступа
не отображаются разделы
Архив версий
Установка стиля на Intellect Board 2.22
Завершилась работа над новой версией 3.00

Самые активные 5 тем RSS


Время выполнения скрипта: 0.0690. Количество выполненных запросов: 17, время выполнения запросов 0.0000
Creative Commons License Rambler's Top100 Rambler's Top100 Рейтинг@Mail.ru Valid HTML 4.01 Transitional Valid CSS!