Intellect Board — cистема управления сайтом

Построение сайта на основе форума

Intellect Board — cистема управления сайтом »   Техническая поддержка версии 2.20 »   Обновление структуры базы данных - Ошибка!
RSS

Обновление структуры базы данных - Ошибка!

Неудачная попытка перейти с 2.19 на 2.20.

Текущий рейтинг темы: Нет
Выводить сообщения

<<Назад  Страницы: 1 2 3 4
Модераторы: aerograf, wsx
Печать
 
4X_Pro
Руководитель Проекта
Настоящий Компьютерщик
4X_Pro
Откуда: Москва
Всего сообщений: 3299
Рейтинг пользователя: 70


Ссылка


Дата регистрации на форуме:
29 сен. 2001

gedeon написал:
[q]
ХХХХPRO, а почему вы английский не знаете - вы же программист. Как вы можете быть хорошим программистом без знания английского? Вам надо английский учить!
[/q]

Странная аналогия. Вы что, хотите сказать, что есть программисты, которые не знают английского? Как же они документацию читать будут?

---
Спорить со мной по поводу того, что в IntB будет, а чего нет -- бесполезно!
4X_Pro
Руководитель Проекта
Настоящий Компьютерщик
4X_Pro
Откуда: Москва
Всего сообщений: 3299
Рейтинг пользователя: 70


Ссылка


Дата регистрации на форуме:
29 сен. 2001

gedeon написал:
[q]
Неопнятно тогда - а зачем вам это надо тогда? Сидеть придумывать чего то. Тем более сами говорите, что это вам неинтересно и вы в перспективу не верите.
[/q]

Уточняю: в перспективу конкретно версий 2.x, а не форумного движка вообще. Мне сейчас вообще было бы гораздо выгоднее бросить бросить ветвь 2.x вообще (у меня самого, как это ни странно, все работает и здесь, и на других проектах) и заниматься только 3.x (заодно избавившись от недовольных, которых тут накопилось довольно много).
И если вы продолжите занимать такую неконструктивную позицию, как сейчас, то я именно так и буду вынужден сделать.

Оффтопик: И вообще, у меня складывается впечатление, что если бы я вместо автоматизированного инсталлятора написал "в файле config/mysql219.sql лежат запросы для обновления форума с 2.19 до 2.20, вам нужно заменить там prefix_ на свой префикс, и выполнить их, а если возникнут ошибки — проигнорировать, то проблем было бы меньше.

---
Спорить со мной по поводу того, что в IntB будет, а чего нет -- бесполезно!
pashk_a
Новичок


Всего сообщений: 25
Рейтинг пользователя: -1


Ссылка


Дата регистрации на форуме:
29 авг. 2006

XXXX Pro написал:
[q]
И вообще, у меня складывается впечатление, что если бы я вместо автоматизированного инсталлятора написал "в файле config/mysql219.sql лежат запросы для обновления форума с 2.19 до 2.20, вам нужно заменить там prefix_ на свой префикс, и выполнить их, а если возникнут ошибки — проигнорировать, то проблем было бы меньше.
[/q]

[moderated]
Uri
Долгожитель форума

Uri
Всего сообщений: 571
Рейтинг пользователя: 4


Ссылка


Дата регистрации на форуме:
25 окт. 2005

XXXX Pro написал:
[q]
gedeon, ну так что мешало как всем нормальным людям делать копии через PhpMyAdmin?
[/q]
Хоть стоит обращение к gedeon'у, я, всё-же отвечу. Поскольку отношу себя к нормальным людям. Но не делаю копии через PhpMyAdmin. Интересно, а откуда взялась взаимосвязь между нормальностью и PhpMyAdmin? С чего, XXXX Pro, Вы взяли, что любому пользователю IB доступенPhpMyAdmin?
Uri
Долгожитель форума

Uri
Всего сообщений: 571
Рейтинг пользователя: 4


Ссылка


Дата регистрации на форуме:
25 окт. 2005

XXXX Pro написал:
[q]
Ну и вообще, не понимаю я такой позциии: "я не знаю того-то и того-то, поэтому вы виноваты". Просто не понимаю.
[/q]
Вас обвиняют не в наличии ошибок (от них никто не застрахован), а в неадекватной реакции на сообщения пользователей об ошибках. И в том, что Вы рекомендуете ("всем рекомендуется переходить на нее уже сейчас", "версия была оттестирована на этом форуме и на socioclub.org") непроверенный ("Там два запроса склеились в один") продукт.
Uri
Долгожитель форума

Uri
Всего сообщений: 571
Рейтинг пользователя: 4


Ссылка


Дата регистрации на форуме:
25 окт. 2005
Меня никто не уполномачивал говорить от имени всех пользователей. Поэтому можно считать это моим личным мнением. Но, полагаю, что похоже думают многие.
Вот я начал тему, задал вопрос. И что, где ответ? Если бы пользователи были спецами, им бы вообще не потребовался Ваш движок. Они написали бы свой.
Многие пользователи не попали бы в зависимость от Вас, если бы Вы прямо написали, что Ваш движок предназначен исключительно для тех, кто знает "PHP, MySQL, HTML, Apache, и Unix системы". А теперь у форумов приличное наполнение, а конверторы сущечтвуют только в 1 сторону. Ну или я не видел конвертеров с IB на что-то другое.

А теперь ещё и угрозы вообще бросить пользователей:
[q]
бросить ветвь 2.x вообще ... (заодно избавившись от недовольных, которых тут накопилось довольно много).
И если вы продолжите занимать такую неконструктивную позицию, как сейчас, то я именно так и буду вынужден сделать.
[/q]

А для кого Вы будете писать 3 версию? Только для себя лично? Или станете как-то отбирать только всем довольных пользователей?
Похоже я начинаю повторять написанное тут. ... Мне (многим, полагаю, тоже) нужен всего лишь инструмент для публикации информации. А вовсе не конструктор, в котором всё время надо что-то настраивать. И вопросы в этом форуме Вам задают не спецы в "PHP, MySQL, HTML, Apache, и Unix". Попробуйте в своих ответах опуститься до нашего, пользовательского уровня знаний.

Я так и не понял, как корректно перейти на 2.20. Надо ли это делать? Будет ли поддержка 2.хх в будущем?
4X_Pro
Руководитель Проекта
Настоящий Компьютерщик
4X_Pro
Откуда: Москва
Всего сообщений: 3299
Рейтинг пользователя: 70


Ссылка


Дата регистрации на форуме:
29 сен. 2001
Попробую ответить по порядку.
1. Насчет встроенных средств backupа: они писались именно по просьбе кого-то из пользователей, кто стоял на бесплатном хостинге. И под "нормальных людей" имелась в виду вовсе не психическая нормальность (или еще какая-нибудь), а наличие нормального хостинга с phpMyAdmin.
2. Насчет рекомендации по ускоренному переходу: это реакция на то, что меня торопят с исправлением ошибок. Выкладывать отдельно исправления для ошибок старой версии и вести разработку новой — это увеличить трудоемкость в 2 с лишним раза, соответственно, я форсирую переход на новую версию ради того, чтобы исправить старые ошибки (пусть даже ценой появления новых).
3. Переход с версии на версию вообще наиболее трудно оттестировать, чем что-либо еще: при каждом шаге требуется сносить все, ставить 2.19, и потом уже обновлять ее до 2.20. В результате я дохожу до некоторого уровня, когда считаю "на следующем запуске ошибок не должно возникнуть" и в таком виде и выкладываю. (В частности, ошибку со склеиванием я все-же находил при переносе своих движков, но скорее всего, исправил файл на FTP, а не на локали, отчего это и ушло в дистрибутив).
4. Что касается поддержки, то думаю да, если конечно, все поголовно не займут позиции как у этого pashk_a.
5. Переходить на 2.20 надо, инструкцию сейчас положу в отдельную тему, а то сейчас она разбросана кусками по двум темам.

---
Спорить со мной по поводу того, что в IntB будет, а чего нет -- бесполезно!
Yuras
Долгожитель форума


Всего сообщений: 382
Рейтинг пользователя: 11


Ссылка


Дата регистрации на форуме:
15 мар. 2007
Ребята, ну ведь видно было желание XXXX Pro поскорее порадовать нас выходом бетки 2.20! \":)\"
А про то, что дамп надо делать перед какими-либо серьезными процедурами - должно стать обязательным правилом апдейта. И уж какими способами это делать, имхо, разработчик совсем не обязан пояснять. Средствами движка, который обновляется, делать бакуп по крайней мере немного опрометчиво.
Пользуйтесь для бакупов базы dumper'ом - http://sypex.net/ Очень удобная штука.
Uri
Долгожитель форума

Uri
Всего сообщений: 571
Рейтинг пользователя: 4


Ссылка


Дата регистрации на форуме:
25 окт. 2005
Я по-прежнему не понял где взять исправленный инсталлятор 2.20. Я так понял, что баг в нём уже не 1 найден. Инструкцию прочитал, спасибо. Но не нашёл ни исправленного инсталлятора, ни явного (я не спец в SQL и "Там два запроса склеились в один" для меня не самая очевидная вещь) указания что исправить в имеющемся.
assessor
Долгожитель форума


Всего сообщений: 495
Рейтинг пользователя: 14


Ссылка


Дата регистрации на форуме:
13 фев. 2007

Yuras написал:
[q]
Ребята, ну ведь видно было желание XXXX Pro поскорее порадовать нас выходом бетки 2.20!
[/q]

Понятно, для нас ведь старается. Правда некоторые вещи можно ему и поподробнее описывать.
Например, что касается базы данных. Если в PHP и CSS мы разберемся, то в остальных вещах надо бы поподробнее.


Yuras написал:
[q]
...А про то, что дамп надо делать перед какими-либо серьезными процедурами - должно стать обязательным правилом апдейта. И уж какими способами это делать, имхо, разработчик совсем не обязан пояснять. ....
Пользуйтесь для бакупов базы dumper'ом - http://sypex.net/ Очень удобная штука.
[/q]

Спасибо Юрас за подсказку скрипта бэкапа.
<<Назад  Страницы: 1 2 3 4
Модераторы: aerograf, wsx
Печать
Intellect Board — cистема управления сайтом »   Техническая поддержка версии 2.20 »   Обновление структуры базы данных - Ошибка!
RSS

1 посетитель просмотрел эту тему за последние 10 минут
В том числе: 1 гость, 0 скрытых пользователей

Последние RSS
Ограничение доступа
не отображаются разделы
Архив версий
Установка стиля на Intellect Board 2.22
Завершилась работа над новой версией 3.00

Самые активные 5 тем RSS


Время выполнения скрипта: 0.1066. Количество выполненных запросов: 17, время выполнения запросов 0.0000
Creative Commons License Rambler's Top100 Rambler's Top100 Рейтинг@Mail.ru Valid HTML 4.01 Transitional Valid CSS!